iPhone connected to WiFi hotspot - but App can't connect

I just tried to setup a Bolt IoT device

After powering up (from an USB power adapter, blue LED flashing slowly), I successfully connected my iPhone to its WiFi hotspot (mobile data switched off, Bolt5436106, password bolt1234).

But after pressing “Continue” in the IOS App, I only get the error message “Not Connected, Make sure your device is connected to BOLT hotspot”

How can I proceed?

Good eve brother,
if you are facing this kind of issue either you have some fault in your bolt module or may i know your power adapter voltage it should be less than 5V.
I hope this may help you.

Thank you very much for your response!

I’ve tried several power adapters (all of them were able to provide 1A, at least) but without any success.

Additionally, I experienced temporary problems when my iPhone tried to connect to the Bolt IoT hotspot - it usually took several attempts before a connection could be made.

Does this sound as if my module could be broken?


actually, there should be a different, fundamental problem: I’ve tried

  • several Bolt IoT modules (I have 8 of them)
  • several power adapters (providing 1A and more)
  • several computers (iPhone, iPad Pro, Macbook Air with M1 chip which can run IOS apps)

Always with the same results:

  • it’s difficult to connect to the Bolt hotspots (usually, it takes more than 3 attempts before a connection can be made)
  • the Bolt app NEVER recognizes any module as connected

Right now, none of the modules seems to be usable

Hi @a-rozek

We will need more details from you to pinpoint the issue. Let me know when you are free today(23rd November 2022) at 04:00 PM for an e-meeting. We shall have a zoom meeting to get more insights into your problem and fix it for you.

which time zone? I am MET

@a-rozek 4:00 PM IST is going to be 11:30 AM Wednesday, Middle European Time (MET). Let me know if you are free.

I will be available, who will start the Zoom session and send an invitation?

Hi @a-rozek I have messaged you via the forum. Do reply back with your email id to it.

done, EMail address has been sent

I have a zoom session running, just look into your email for an invitation

Hi @a-rozek As discussed in the meeting, I shall check this with the tech team and share the workaround for the issue you are facing.

Thanks in advance for your effort!

Good afternoon!

I may have found an issue with your Bolt IoT Setup app: this morning, it came into my mind that I still own an old Amazon Kindle FireHD device - thus, I charged it and gave it a try.

Outcome: the setup app seems to require a location service (why? I don’t see any reason for it) but my Kindle FireHD does not seem to have such - as a consequence, I got stuck when the app asked me to switch on a “high-accuracy location” or a “device-only location” service.

I.e., setup does not work on my Kindle FireHD either.

Good afternoon!

I also reactivated an old HTC One mini with Android in order to test the Bolt Setup app.

I was again asked to activate the high accuracy location service for which I do not see any reason.

But, even then, I got stuck: right now I am asked to deactivate mobile data transfer - but I can’t because I do not have any SIM card for that mobile phone and am using Wifi only instead. Within the settings app, the switch to deactivate mobile data is greyed out and cannot be toggled.

I now tried two IOS, a FireOS and an Android device and always failed connecting to the Bolt module. Since a Wifi connection to the module seems to be established (the blue LED is flashing rapidly) it looks as if your app seems to be the problem…

Hi @a-rozek

With the Bolt WiFi modules blue LED blinking slowly(in hotspot mode), Connect your laptop to the hotspot. The hotspot SSID will be the Bolt ID and the password will be bolt1234. Once your laptop is connected to the Bolt hotspot, open the browser and visit the URL:

Where SSID_name: is the WiFi network you want to connect the Bolt module to and Password is that of the network.

Note: Encode the and via https://www.url-encode-decode.com/ and replace them in the above URL.

Once this is done, the Green LED should come on, indicating that it is connected to the bolt cloud via the internet.

Explanation. In hotspot mode, the Bolt WiFi module has the IP hardcoded onto it. And it runs a webserver. With the above URL, we simply connect to that web server and give it the WiFi credentials. This is usually done automatically in the Smartphone app setup.

Let me know if you need help with doing this, we can have another Video session where I can guide you through these steps.

Very well done!

Following your instructions, I was able to setup my Bolt module without any problems - it is so simple that you should consider developing a Web App which does the setup (or publish the receipt for a “cURL” command if somebody wants to setup a device from the command line)

Again, this looks as if your iOS and Android setup apps seem to cause my problems…

Thanks anyway for your effort!


with the green LED switched on I tried to use my Bolt module - but the app does not know about it. Even after log-out and log-in the list of added devices remains empty…

It does not even appear in the list of devices within Bolt Cloud.

At least, I found the module in my wifi network at home: it calls itself “ESP_xxxxxx” with 6 hexadecimal digits.

But how should I proceed from here? How can I attach the module to my Bolt account?

I meanwhile found a method to attach a bolt module to my account in the discussion Re-register bolt IoT and did so with my device. I got the response

{"reply":"Registration attempted successfully xxx@xxx.de
 Visit cloud.boltiot.com for confirmation 

but the device does not show up in Bolt Cloud.

How should I proceed?